using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\(((?>[^()]+|(?1))*)\))|\G(?!^)(?:\s*(\w+)\s*)(?=\())";
string input = @"((weight gt 10) OR (weight lt 100)) AND (length lt 50)
(length lt 50) AND ((weight gt 10) OR (weight lt 100))
((weight gt 10) OR (weight lt 100)) AND (length lt 50) AND (length lt 50)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}