#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^0[123]*(?:{[^{}]*}[123]*)*0"
Local $sString = "0213123123130" & @CRLF & _
"012312312312303123123" & @CRLF & _
"01231230123123031230" & @CRLF & _
"01232231{whatever 3 gArBaGe? I want.}121{foo}2310312{bar}3120123" & @CRLF & _
"01212121{hello 0}121312" & @CRLF & _
"01213123123123{21310030123012301}31231230123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")