// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0[123]*(?:{[^{}]*}[123]*)*0").unwrap();
let string = "0213123123130
012312312312303123123
01231230123123031230
01232231{whatever 3 gArBaGe? I want.}121{foo}2310312{bar}3120123
01212121{hello 0}121312
01213123123123{21310030123012301}31231230123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}