use strict;
my $str = '0213123123130
012312312312303123123
01231230123123031230
01232231{whatever 3 gArBaGe? I want.}121{foo}2310312{bar}3120123
01212121{hello 0}121312
01213123123123{21310030123012301}31231230123';
my $regex = qr/^0[123]*(?:{[^{}]*}[123]*)*0/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}