package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^0[123]*(?:{[^{}]*}[123]*)*0`)
var str = `0213123123130
012312312312303123123
01231230123123031230
01232231{whatever 3 gArBaGe? I want.}121{foo}2310312{bar}3120123
01212121{hello 0}121312
01213123123123{21310030123012301}31231230123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}