# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^0[123]*(?:{[^{}]*}[123]*)*0"
test_str = ("0213123123130\n"
"012312312312303123123\n"
"01231230123123031230\n"
"01232231{whatever 3 gArBaGe? I want.}121{foo}2310312{bar}3120123\n"
"01212121{hello 0}121312\n"
"01213123123123{21310030123012301}31231230123")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.