using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?:new |\((?!new))([A-Z][\w]+))|([A-Z][\w]+)::";
string input = @"new User
new hej
(user()
new LOl fsdfdsf
User::";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}