#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:00?|\+)3[3-5]0?|(?!\n)\W"
Local $sString = "+331234567" & @CRLF & _
"+3301234567" & @CRLF & _
"00331234567" & @CRLF & _
"003301234567" & @CRLF & _
"0331234567" & @CRLF & _
"033-123-456-7" & @CRLF & _
"0033.1234567"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)