using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:00?|\+)3[3-5]0?|(?!\n)\W";
string substitution = @"";
string input = @"+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}