use strict;
my $str = '+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567';
my $regex = qr/^(?:00?|\+)3[3-5]0?|(?!\n)\W/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";