re = /^(?:00?|\+)3[3-5]0?|(?!\n)\W/m
str = '+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result