const regex = /^(?:00?|\+)3[3-5]0?|(?!\n)\W/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:00?|\\+)3[3-5]0?|(?!\\n)\\W', 'gm')
const str = `+331234567
+3301234567
00331234567
003301234567
0331234567
033-123-456-7
0033.1234567`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);