import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<!--.*?-->|<style[\\S\\s\\n]*?<\\/style>|<script[\\S\\s\\n]*?<\\/script>|rgb\\(\\d+,\\x20\\d+,\\x20\\d+\\))(*SKIP)(*F)|\\((.+?)\\)\\s*again";
final String string = "<!-- (Male) -->\n"
+ "<p>(Malē) again</p>\n"
+ "<p style=\"font-family: "verdana"; font-size: 18px; color: rgb(0, 0, 0);\">Malē again</p>\n"
+ "<style>\n"
+ "code {\n"
+ " font-family: "verdana";\n"
+ " font-size: 18px;\n"
+ " color: black;\n"
+ " font-weight: bold !important;\n"
+ " line-height: 1.6 !important;\n"
+ " }\n"
+ "@media (min-width: 1281px) {\n"
+ "code {\n"
+ " font: 24px \"verdana\" bold !important;\n"
+ " }\n"
+ "}\n"
+ "</style>\n"
+ "<script type=\"text/javascript\">\n"
+ "function googleTranslateElementInit() {\n"
+ " new google.translate.TranslateElement({pageLanguage: 'en'}, 'google_translate_element');\n"
+ "}\n"
+ "</script>";
final String subst = "$1 - again";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}