# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<!--.*?-->|<style[\S\s\n]*?<\/style>|<script[\S\s\n]*?<\/script>|rgb\(\d+,\x20\d+,\x20\d+\))(*SKIP)(*F)|\((.+?)\)\s*again"
test_str = ("<!-- (Male) -->\n"
"<p>(Malē) again</p>\n"
"<p style=\"font-family: "verdana"; font-size: 18px; color: rgb(0, 0, 0);\">Malē again</p>\n"
"<style>\n"
"code {\n"
" font-family: "verdana";\n"
" font-size: 18px;\n"
" color: black;\n"
" font-weight: bold !important;\n"
" line-height: 1.6 !important;\n"
" }\n"
"@media (min-width: 1281px) {\n"
"code {\n"
" font: 24px \"verdana\" bold !important;\n"
" }\n"
"}\n"
"</style>\n"
"<script type=\"text/javascript\">\n"
"function googleTranslateElementInit() {\n"
" new google.translate.TranslateElement({pageLanguage: 'en'}, 'google_translate_element');\n"
"}\n"
"</script>")
subst = "$1 - again"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.