// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:<!--.*?-->|<style[\S\s\n]*?<\/style>|<script[\S\s\n]*?<\/script>|rgb\(\d+,\x20\d+,\x20\d+\))(*SKIP)(*F)|\((.+?)\)\s*again").unwrap();
let string = "<!-- (Male) -->
<p>(Malē) again</p>
<p style=\"font-family: "verdana"; font-size: 18px; color: rgb(0, 0, 0);\">Malē again</p>
<style>
code {
font-family: "verdana";
font-size: 18px;
color: black;
font-weight: bold !important;
line-height: 1.6 !important;
}
@media (min-width: 1281px) {
code {
font: 24px \"verdana\" bold !important;
}
}
</style>
<script type=\"text/javascript\">
function googleTranslateElementInit() {
new google.translate.TranslateElement({pageLanguage: 'en'}, 'google_translate_element');
}
</script>";
let substitution = "$1 - again";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}