using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Client:\s*(.*)[\r\n][\s\S]*?^Price \(USD\):\s*(.*)[\r\n][\s\S]*?^Time:\s*(.*)[\r\n][\s\S]*?^Project Id:\s*(\w+)";
string input = @"Package Summary:
Client: WISE EMPLOYMENT LTD
Account Executive: asd Vas
Price (USD): 3,000
Time: 1 Week
Global Region: APAC
Project Id: 21312
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}