package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Client:\s*(.*)[\r\n][\s\S]*?^Price \(USD\):\s*(.*)[\r\n][\s\S]*?^Time:\s*(.*)[\r\n][\s\S]*?^Project Id:\s*(\w+)`)
var str = `Package Summary:
Client: WISE EMPLOYMENT LTD
Account Executive: asd Vas
Price (USD): 3,000
Time: 1 Week
Global Region: APAC
Project Id: 21312
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}