import re
regex = re.compile(r"Client:\s*(.*)[\r\n][\s\S]*?^Price \(USD\):\s*(.*)[\r\n][\s\S]*?^Time:\s*(.*)[\r\n][\s\S]*?^Project Id:\s*(\w+)", flags=re.MULTILINE)
test_str = ("Package Summary:\n"
"Client: WISE EMPLOYMENT LTD\n"
"Account Executive: asd Vas\n"
"Price (USD): 3,000\n"
"Time: 1 Week\n"
"Global Region: APAC\n"
"Project Id: 21312\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")