re = /Client:\s*(.*)[\r\n][\s\S]*?^Price \(USD\):\s*(.*)[\r\n][\s\S]*?^Time:\s*(.*)[\r\n][\s\S]*?^Project Id:\s*(\w+)/m
str = 'Package Summary:
Client: WISE EMPLOYMENT LTD
Account Executive: asd Vas
Price (USD): 3,000
Time: 1 Week
Global Region: APAC
Project Id: 21312
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end