import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Client:\\s*(.*)[\\r\\n][\\s\\S]*?^Price \\(USD\\):\\s*(.*)[\\r\\n][\\s\\S]*?^Time:\\s*(.*)[\\r\\n][\\s\\S]*?^Project Id:\\s*(\\w+)";
final String string = "Package Summary:\n"
+ "Client: WISE EMPLOYMENT LTD\n"
+ "Account Executive: asd Vas\n"
+ "Price (USD): 3,000\n"
+ "Time: 1 Week\n"
+ "Global Region: APAC\n"
+ "Project Id: 21312\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}