#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)OEM[]]]><[\/]Name><Value>(.*)(?=<[\/]Value><[\/]NameValueList)"
Local $sString = "<NameValueList><Name><![CD[OEM]]></Name><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value></NameValueList><NameValueList><Name><![CD[AAA]]></Name><Value><![CD[11111]]></Value></NameValueList><NameValueList><Name><![CD[EAN]]></Name><Value><![CD[XXX]]></Value></NameValueList><NameValueList><Name><![CD[bla]]></Name><Value><![CD[BLE]]></Value></NameValueList><NameValueList><Name><![CD[MOD]]></Name><Value><![CD[BLU]]></Value></NameValueList><NameValueList><Name><![CD[ORG]]></Name><Value><![CD[Made in Germany!]]></Value></NameValueList></ItemSpecifics>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")