import Foundation
let pattern = #"OEM[]]]><[\/]Name><Value>(.*)(?=<[\/]Value><[\/]NameValueList)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<NameValueList><Name><![CD[OEM]]></Name><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value></NameValueList><NameValueList><Name><![CD[AAA]]></Name><Value><![CD[11111]]></Value></NameValueList><NameValueList><Name><![CD[EAN]]></Name><Value><![CD[XXX]]></Value></NameValueList><NameValueList><Name><![CD[bla]]></Name><Value><![CD[BLE]]></Value></NameValueList><NameValueList><Name><![CD[MOD]]></Name><Value><![CD[BLU]]></Value></NameValueList><NameValueList><Name><![CD[ORG]]></Name><Value><![CD[Made in Germany!]]></Value></NameValueList></ItemSpecifics>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)