using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"OEM[]]]><[\/]Name><Value>(.*)(?=<[\/]Value><[\/]NameValueList)";
string input = @"<NameValueList><Name><![CD[OEM]]></Name><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value></NameValueList><NameValueList><Name><![CD[AAA]]></Name><Value><![CD[11111]]></Value></NameValueList><NameValueList><Name><![CD[EAN]]></Name><Value><![CD[XXX]]></Value></NameValueList><NameValueList><Name><![CD[bla]]></Name><Value><![CD[BLE]]></Value></NameValueList><NameValueList><Name><![CD[MOD]]></Name><Value><![CD[BLU]]></Value></NameValueList><NameValueList><Name><![CD[ORG]]></Name><Value><![CD[Made in Germany!]]></Value></NameValueList></ItemSpecifics>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}