re = /OEM[]]]><[\/]Name><Value>(.*)(?=<[\/]Value><[\/]NameValueList)/m
str = '<NameValueList><Name><![CD[OEM]]></Name><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value></NameValueList><NameValueList><Name><![CD[AAA]]></Name><Value><![CD[11111]]></Value></NameValueList><NameValueList><Name><![CD[EAN]]></Name><Value><![CD[XXX]]></Value></NameValueList><NameValueList><Name><![CD[bla]]></Name><Value><![CD[BLE]]></Value></NameValueList><NameValueList><Name><![CD[MOD]]></Name><Value><![CD[BLU]]></Value></NameValueList><NameValueList><Name><![CD[ORG]]></Name><Value><![CD[Made in Germany!]]></Value></NameValueList></ItemSpecifics>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end