# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"OEM[]]]><[\/]Name><Value>(.*)(?=<[\/]Value><[\/]NameValueList)"
test_str = "<NameValueList><Name><![CD[OEM]]></Name><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value><Value><![CD[TESTDATA]]></Value></NameValueList><NameValueList><Name><![CD[AAA]]></Name><Value><![CD[11111]]></Value></NameValueList><NameValueList><Name><![CD[EAN]]></Name><Value><![CD[XXX]]></Value></NameValueList><NameValueList><Name><![CD[bla]]></Name><Value><![CD[BLE]]></Value></NameValueList><NameValueList><Name><![CD[MOD]]></Name><Value><![CD[BLU]]></Value></NameValueList><NameValueList><Name><![CD[ORG]]></Name><Value><![CD[Made in Germany!]]></Value></NameValueList></ItemSpecifics>"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.