#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)\{" & @CRLF & _
" \s* ([a-zA-Z_][a-zA-Z0-9_-]*) \s*" & @CRLF & _
" (?:" & @CRLF & _
" : \s* ([^{}]*(?:\{(?-1)\}[^{}]*)*)" & @CRLF & _
" )?" & @CRLF & _
"\}"
Local $sString = "{hello}" & @CRLF & _
"{hello:xxx}" & @CRLF & _
"{hello:xxx{yyy}}" & @CRLF & _
"{hello:xxx{yyy:zzz}aaa}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")