import re
regex = re.compile(r"""
\{
\s* ([a-zA-Z_][a-zA-Z0-9_-]*) \s*
(?:
: \s* ([^{}]*(?:\{(?-1)\}[^{}]*)*)
)?
\}
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("{hello}\n"
"{hello:xxx}\n"
"{hello:xxx{yyy}}\n"
"{hello:xxx{yyy:zzz}aaa}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")