import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{\n"
+ " \\s* ([a-zA-Z_][a-zA-Z0-9_-]*) \\s*\n"
+ " (?:\n"
+ " : \\s* ([^\\{\\}]*(?:\\{(?-1)\\}[^\\{\\}]*)*)\n"
+ " )?\n"
+ "\\}";
final String string = "{hello}\n"
+ "{hello:xxx}\n"
+ "{hello:xxx{yyy}}\n"
+ "{hello:xxx{yyy:zzz}aaa}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}