$re = '/\{
\s* ([a-zA-Z_][a-zA-Z0-9_-]*) \s*
(?:
: \s* ([^{}]*(?:\{(?-1)\}[^{}]*)*)
)?
\}/mx';
$str = '{hello}
{hello:xxx}
{hello:xxx{yyy}}
{hello:xxx{yyy:zzz}aaa}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);