package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[0-9]{10}\b`)
var str = `National Provider Identifier
Requirements: 10 consecutive digit number
Pattern:
\b[0-9]{10}\b
Test Cases:
Positive (should fire):
10 digits consecutively 1234507890
Embedded in text with spaces NPI: oops 1234507890 there is text here
Negative (should not fire):
Too many digits 12345078901
Not consecutive 1234567-890
Embedded in text no spaces oops1234507890there is text here
Phone number formats:
2028080012 (this one will fire, false positive)
202-808-0012
202.808.0012
202 808 0012 `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}