import Foundation
let pattern = #"\b[0-9]{10}\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
National Provider Identifier
Requirements: 10 consecutive digit number
Pattern:
\b[0-9]{10}\b
Test Cases:
Positive (should fire):
10 digits consecutively 1234507890
Embedded in text with spaces NPI: oops 1234507890 there is text here
Negative (should not fire):
Too many digits 12345078901
Not consecutive 1234567-890
Embedded in text no spaces oops1234507890there is text here
Phone number formats:
2028080012 (this one will fire, false positive)
202-808-0012
202.808.0012
202 808 0012
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)