// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\b[0-9]{10}\b").unwrap();
let string = "National Provider Identifier
Requirements: 10 consecutive digit number
Pattern:
\\b[0-9]{10}\\b
Test Cases:
Positive (should fire):
10 digits consecutively 1234507890
Embedded in text with spaces NPI: oops 1234507890 there is text here
Negative (should not fire):
Too many digits 12345078901
Not consecutive 1234567-890
Embedded in text no spaces oops1234507890there is text here
Phone number formats:
2028080012 (this one will fire, false positive)
202-808-0012
202.808.0012
202 808 0012 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}