# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\b[0-9]{10}\b"
test_str = ("National Provider Identifier\n"
"Requirements: 10 consecutive digit number\n\n"
"Pattern:\n"
"\\b[0-9]{10}\\b\n\n"
"Test Cases:\n"
"Positive (should fire):\n"
"10 digits consecutively 1234507890\n"
"Embedded in text with spaces NPI: oops 1234507890 there is text here\n\n"
"Negative (should not fire):\n"
"Too many digits 12345078901\n"
"Not consecutive 1234567-890\n\n"
"Embedded in text no spaces oops1234507890there is text here\n\n"
"Phone number formats:\n"
"2028080012 (this one will fire, false positive)\n"
"202-808-0012\n"
"202.808.0012\n"
"202 808 0012 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.