#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<category>[APDRF])(?<dimensionCode>[A-Z0-9])(?<contourOrCertification>[A-Z0-9])_?(?<serialNumber>[0-9]{3,5})_?(?<ownerCode>[A-Z0-9]{2,3})$"
Local $sString = "AKE12345ZZ" & @CRLF & _
"PMC1234ZZ" & @CRLF & _
"AKE_12345_ZZ" & @CRLF & _
"AKE6527T2" & @CRLF & _
"AMH44000LH" & @CRLF & _
"AKH057GWI" & @CRLF & _
"AKE31677QF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")