import Foundation
let pattern = #"^(?<category>[APDRF])(?<dimensionCode>[A-Z0-9])(?<contourOrCertification>[A-Z0-9])_?(?<serialNumber>[0-9]{3,5})_?(?<ownerCode>[A-Z0-9]{2,3})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
AKE12345ZZ
PMC1234ZZ
AKE_12345_ZZ
AKE6527T2
AMH44000LH
AKH057GWI
AKE31677QF
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)