package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<category>[APDRF])(?<dimensionCode>[A-Z0-9])(?<contourOrCertification>[A-Z0-9])_?(?<serialNumber>[0-9]{3,5})_?(?<ownerCode>[A-Z0-9]{2,3})$`)
var str = `AKE12345ZZ
PMC1234ZZ
AKE_12345_ZZ
AKE6527T2
AMH44000LH
AKH057GWI
AKE31677QF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}