use strict;
my $str = 'AKE12345ZZ
PMC1234ZZ
AKE_12345_ZZ
AKE6527T2
AMH44000LH
AKH057GWI
AKE31677QF';
my $regex = qr/^(?<category>[APDRF])(?<dimensionCode>[A-Z0-9])(?<contourOrCertification>[A-Z0-9])_?(?<serialNumber>[0-9]{3,5})_?(?<ownerCode>[A-Z0-9]{2,3})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}