$re = '/^(?<category>[APDRF])(?<dimensionCode>[A-Z0-9])(?<contourOrCertification>[A-Z0-9])_?(?<serialNumber>[0-9]{3,5})_?(?<ownerCode>[A-Z0-9]{2,3})$/m';
$str = 'AKE12345ZZ
PMC1234ZZ
AKE_12345_ZZ
AKE6527T2
AMH44000LH
AKH057GWI
AKE31677QF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);