const regex = /\b[a-z]\b\s*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-z]\\b\\s*', 'gmi')
const str = `A abc, B xyz, C mlk ooo`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);