use strict;
my $str = 'A abc, B xyz, C mlk ooo';
my $regex = qr/\b[a-z]\b\s*/mip;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";