$re = '/\b[a-z]\b\s*/mi';
$str = 'A abc, B xyz, C mlk ooo';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;