import re
regex = re.compile(r"\b[a-z]\b\s*", flags=re.MULTILINE | re.IGNORECASE)
test_str = "A abc, B xyz, C mlk ooo"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)