import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!^\\/api\\/auth\\/|\\/(favicon|icon|apple-icon)\\.(ico|jpg|jpeg|png|svg)$|^\\/(assets|public)\\/).)*$";
final String string = "## Next.js middleware config matcher regex\n"
+ "# ~ https://nextjs.org/docs/app/building-your-application/routing/middleware#matcher\n"
+ "# ~ https://nextjs.org/docs/app/api-reference/file-conventions/middleware#config-object-optional\n\n"
+ "# Public - skip middleware\n"
+ "/api/auth/*\n"
+ "/favicon.ico\n"
+ "/assets/*\n"
+ "/public/*\n\n"
+ "# Private - use middleware\n"
+ "/*\n"
+ "/api/*\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}