re = /^((?!^\/api\/auth\/|\/(favicon|icon|apple-icon)\.(ico|jpg|jpeg|png|svg)$|^\/(assets|public)\/).)*$/m
str = '## Next.js middleware config matcher regex
# ~ https://nextjs.org/docs/app/building-your-application/routing/middleware#matcher
# ~ https://nextjs.org/docs/app/api-reference/file-conventions/middleware#config-object-optional
# Public - skip middleware
/api/auth/*
/favicon.ico
/assets/*
/public/*
# Private - use middleware
/*
/api/*
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end