use strict;
my $str = '## Next.js middleware config matcher regex
# ~ https://nextjs.org/docs/app/building-your-application/routing/middleware#matcher
# ~ https://nextjs.org/docs/app/api-reference/file-conventions/middleware#config-object-optional
# Public - skip middleware
/api/auth/*
/favicon.ico
/assets/*
/public/*
# Private - use middleware
/*
/api/*
';
my $regex = qr/^((?!^\/api\/auth\/|\/(favicon|icon|apple-icon)\.(ico|jpg|jpeg|png|svg)$|^\/(assets|public)\/).)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}