# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^((?!^\/api\/auth\/|\/(favicon|icon|apple-icon)\.(ico|jpg|jpeg|png|svg)$|^\/(assets|public)\/).)*$"
test_str = ("## Next.js middleware config matcher regex\n"
"# ~ https://nextjs.org/docs/app/building-your-application/routing/middleware#matcher\n"
"# ~ https://nextjs.org/docs/app/api-reference/file-conventions/middleware#config-object-optional\n\n"
"# Public - skip middleware\n"
"/api/auth/*\n"
"/favicon.ico\n"
"/assets/*\n"
"/public/*\n\n"
"# Private - use middleware\n"
"/*\n"
"/api/*\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.