$re = '/(?<=by )((\w+) (\w+))(?:,\s*)?((\w+) (\w+))?(?:\s*(?<=and ))((\w+) (\w+))/mi';
$str = 'By Person One, Person Two and Person Three
By Person One, Person Two
By Person One
By Person Two and Person Three
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);