import re
regex = re.compile(r"(?<=by )((\w+) (\w+))(?:,\s*)?((\w+) (\w+))?(?:\s*(?<=and ))((\w+) (\w+))", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("By Person One, Person Two and Person Three\n"
"By Person One, Person Two\n"
"By Person One\n"
"By Person Two and Person Three\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")