using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/\d{8}(?=/)";
string substitution = @"";
string input = @"2017/07/24204301/a-4.png
2017/07/24204318/a-5-e1501986401369.png
2017/11/24211223/questao10branca-172x300.png";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}