import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "/\\d{8}(?=/)";
final String string = "2017/07/24204301/a-4.png\n"
+ "2017/07/24204318/a-5-e1501986401369.png\n"
+ "2017/11/24211223/questao10branca-172x300.png";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}